Support PCRE2 or PCRE in `build-nginx`